開發者 / 證書

CSR解碼器

解碼PEM憑證簽署要求,查看主體、替代名稱、公開金鑰、簽章演算法與擴充欄位,並在本機檢查簽章。

CSR解碼器: 讀取PKCS#10要求,顯示其主體欄位、主體別名、RSA或EC公開金鑰大小、簽章演算法及要求的擴充欄位。此工具會使用內嵌的公開金鑰,檢查支援的RSA和ECDSA簽章。 全程在瀏覽器中於本機執行,檔案不會上傳至伺服器。

使用次數
在瀏覽器中
費用
免費・免註冊
可用狀態
可立即使用
CSR解碼器本機處理

全程在瀏覽器中執行

憑證簽署要求

PKCS#10定義了包含主體、公開金鑰及要求的擴充功能之已簽署要求。RFC 2986(https://www.rfc-editor.org/rfc/rfc2986)說明其結構。

PEM和憑證結構

RFC 7468(https://www.rfc-editor.org/rfc/rfc7468)定義文字格式的PEM標籤。RFC 5280(https://www.rfc-editor.org/rfc/rfc5280)說明憑證主體和替代名稱。這些格式承載資料,但本身不會建立信任。

使用方式

  1. 貼上一份PEM憑證簽署要求。
  2. 選擇「解碼並驗證」。
  3. 查看主體、要求的擴充欄位和簽章結果。

隱私與限制

所有處理都在瀏覽器中執行。您的圖片、金鑰及貼上的資料不會由此工具上傳或儲存。

相關工具

常見問題

有效的簽章代表什麼?

這表示要求是使用對應的私密金鑰簽署,且簽署內容未遭變更。這並不代表身分已獲確認、憑證授權單位已核准,或已建立信任。

可以檢查哪些簽章?

支援使用SHA-1、SHA-256、SHA-384或SHA-512的RSA PKCS#1簽章,以及使用SHA-256、SHA-384或SHA-512的ECDSA簽章。不支援的簽章,包括RSA-PSS,會顯示為未檢查。

CSR是私密金鑰嗎?

不是。CSR包含公開金鑰和要求的憑證詳細資料。其中的主體資料仍可能具有敏感性,因此此解碼器會將資料保留在您的瀏覽器中。

免費工具・使用在瀏覽器中次・免註冊