開發者 / 證書

憑證金鑰比對工具

在瀏覽器中比對憑證與RSA或EC私密金鑰及/或CSR,確認其公開金鑰是否相符。

憑證金鑰比對工具: 擷取每個公開金鑰,將其轉換為一致的表示形式,再與憑證的公開金鑰進行比對。支援RSA和EC,包括PKCS#8私密金鑰、RSA PKCS#1私密金鑰,以及使用具名曲線參數的EC金鑰。 全程在瀏覽器中於本機執行,檔案不會上傳至伺服器。

使用次數
在瀏覽器中
費用
免費・免註冊
可用狀態
可立即使用
憑證金鑰比對工具本機處理

全程在瀏覽器中執行

金鑰和憑證會留在瀏覽器中。金鑰相符不代表憑證受到信任或仍在有效期內。

公開金鑰表示方式

RFC 5280(https://www.rfc-editor.org/rfc/rfc5280)說明憑證所承載的公開金鑰資訊。比較其標準化表示方式,即可辨識憑證和要求中是否為同一把金鑰。

私密金鑰格式

RFC 5208(https://www.rfc-editor.org/rfc/rfc5208)說明PKCS#8,RFC 5915(https://www.rfc-editor.org/rfc/rfc5915)則說明EC私密金鑰。本頁接受未加密的金鑰,不會要求輸入密碼。

使用方式

  1. 貼上一份PEM憑證。
  2. 貼上未加密的私密金鑰、CSR,或兩者都貼上。
  3. 比對公開金鑰,並查看每個提供物件的結果。

隱私與限制

所有作業都在瀏覽器中執行。您的圖片、金鑰和貼上的資料不會由此工具上傳或儲存。

相關工具

常見問題

比對相符是否代表憑證受到信任?

不是。相符結果只會比對公開金鑰,不會驗證憑證簽章、到期日、主機名稱或信任鏈。

支援加密的私密金鑰嗎?

不支援。請使用未加密的PEM金鑰。金鑰只會在瀏覽器中處理,不會上傳或儲存。

沒有私密金鑰,也可以比對CSR嗎?

可以。貼上憑證和CSR即可比對其公開金鑰。如果您也提供私密金鑰,系統會另外顯示該金鑰的結果。

免費工具・使用在瀏覽器中次・免註冊