Для разработчиков / Сертификаты

Декодер CSR

Декодируйте PEM-запрос на подпись сертификата: субъект, альтернативные имена, открытый ключ, алгоритм подписи и расширения, с локальной проверкой подписи.

Декодер CSR: Читает запрос PKCS#10 и показывает поля субъекта, альтернативные имена субъекта, размер открытого ключа RSA или EC, алгоритм подписи и запрошенные расширения. Проверяет поддерживаемые подписи RSA и ECDSA с использованием встроенного открытого ключа. Работает на 100% локально в вашем браузере, файлы на сервер не загружаются.

Запуски
В вашем браузере
Стоимость
Бесплатно · без регистрации
Доступность
Готово к использованию
Декодер CSRЛокальная обработка

Полностью работает в браузере

Запросы на сертификат

PKCS#10 определяет подписанный запрос, содержащий данные субъекта, открытый ключ и запрошенные расширения. Его структуру описывает RFC 2986 (https://www.rfc-editor.org/rfc/rfc2986).

Структуры PEM и сертификатов

RFC 7468 (https://www.rfc-editor.org/rfc/rfc7468) определяет текстовые метки PEM. RFC 5280 (https://www.rfc-editor.org/rfc/rfc5280) описывает субъектов сертификатов и альтернативные имена. Эти форматы передают данные, но сами по себе не подтверждают доверие.

Как пользоваться

  1. Вставьте один PEM-запрос на подпись сертификата.
  2. Выберите «Декодировать и проверить».
  3. Просмотрите данные субъекта, запрошенные расширения и результат проверки подписи.

Конфиденциальность и ограничения

Всё выполняется в вашем браузере. Ваши изображения, ключи и вставленные данные не загружаются и не сохраняются этим инструментом.

Похожие инструменты

Часто задаваемые вопросы

Что означает действительная подпись?

Это означает, что запрос был подписан соответствующим закрытым ключом, а его подписанное содержимое не изменилось. Это не подтверждает личность, одобрение центра сертификации или доверие.

Какие подписи можно проверить?

Поддерживаются подписи RSA PKCS#1 с SHA-1, SHA-256, SHA-384 или SHA-512, а также ECDSA с SHA-256, SHA-384 или SHA-512. Неподдерживаемая подпись, включая RSA-PSS, отображается как непроверенная.

Является ли CSR закрытым ключом?

Нет. Он содержит открытый ключ и запрошенные данные сертификата. Данные субъекта всё же могут быть конфиденциальными, поэтому этот декодер оставляет их в вашем браузере.

Бесплатный инструмент · запусков: в вашем браузере · аккаунт не нужен