开发者 / 证书

CSR解码器

解码PEM证书签名请求,查看主题、备用名称、公钥、签名算法和扩展,并在本地检查签名。

CSR解码器: 读取PKCS#10请求,并显示其主题字段、主题备用名称、RSA或EC公钥大小、签名算法和请求的扩展。它会使用请求中嵌入的公钥检查受支持的RSA和ECDSA签名。 完全在浏览器中本地运行,文件不会上传到服务器。

使用次数
在浏览器中
费用
免费·无需注册
可用性
可直接使用
CSR解码器本地处理

完全在浏览器中运行

证书请求

PKCS#10定义了包含主题、公钥和请求扩展的签名请求。RFC 2986(https://www.rfc-editor.org/rfc/rfc2986)介绍了其结构。

PEM和证书结构

RFC 7468(https://www.rfc-editor.org/rfc/rfc7468)定义了文本形式的PEM标签。RFC 5280(https://www.rfc-editor.org/rfc/rfc5280)介绍了证书主题和备用名称。这些格式承载数据,但本身不会建立信任关系。

使用方法

  1. 粘贴一个PEM证书签名请求。
  2. 选择“解码并验证”。
  3. 查看主题、请求的扩展和签名结果。

隐私与限制

所有操作都在浏览器中运行。此工具不会上传或保存你的图片、密钥和粘贴的数据。

相关工具

常见问题

有效签名意味着什么?

这表示请求使用相应的私钥签名,且签名内容未发生变化。但这不能证明身份、证书颁发机构的批准或信任关系。

可以检查哪些签名?

支持使用SHA-1、SHA-256、SHA-384或SHA-512的RSA PKCS#1签名,以及使用SHA-256、SHA-384或SHA-512的ECDSA签名。不受支持的签名(包括RSA-PSS)会显示为未检查。

CSR是私钥吗?

不是。CSR包含公钥和请求的证书详细信息。其中的主题数据仍可能具有敏感性,因此此解码器会将其保留在浏览器中。

免费工具·使用在浏览器中次·无需账户