डेवलपर / प्रमाणपत्र
प्रमाणपत्र कुंजी मिलानकर्ता
अपने ब्राउज़र में प्रमाणपत्र और RSA या EC निजी कुंजी और/या CSR की सार्वजनिक कुंजियों का मिलान करें।
प्रमाणपत्र कुंजी मिलानकर्ता: यह प्रत्येक सार्वजनिक कुंजी निकालकर उसे एक समान रूप में बदलता है और प्रमाणपत्र की सार्वजनिक कुंजी से उसकी तुलना करता है। RSA और EC समर्थित हैं, जिनमें PKCS#8 निजी कुंजियाँ, RSA PKCS#1 निजी कुंजियाँ और नामित-वक्र पैरामीटर वाली EC कुंजियाँ शामिल हैं। यह आपके ब्राउज़र में 100% स्थानीय रूप से चलता है और सर्वर पर कोई फ़ाइल अपलोड नहीं होती।
- श्रेणी
- डेवलपर टूल्स
- रन
- आपके ब्राउज़र में
- लागत
- मुफ़्त · साइन अप की ज़रूरत नहीं
- उपलब्धता
- इस्तेमाल के लिए तैयार
पूरी तरह आपके ब्राउज़र में चलता है
कुंजियाँ और प्रमाणपत्र आपके ब्राउज़र में रहते हैं। मेल खाती कुंजियाँ प्रमाणपत्र पर भरोसा या उसकी समय-सीमा समाप्ति स्थापित नहीं करतीं।
Public key का स्वरूप
RFC 5280 (https://www.rfc-editor.org/rfc/rfc5280) सर्टिफ़िकेट में मौजूद public key information का वर्णन करता है। इसके सामान्यीकृत स्वरूप की तुलना करने से सर्टिफ़िकेट और अनुरोध में मौजूद एक ही key की पहचान होती है।
Private key फ़ॉर्मैट
RFC 5208 (https://www.rfc-editor.org/rfc/rfc5208) PKCS#8 का वर्णन करता है, जबकि RFC 5915 (https://www.rfc-editor.org/rfc/rfc5915) EC private keys का वर्णन करता है। यह पेज अनएन्क्रिप्टेड keys स्वीकार करता है और passphrase नहीं मांगता।
इस्तेमाल करने का तरीका
- एक PEM प्रमाणपत्र पेस्ट करें।
- बिना एन्क्रिप्शन वाली निजी कुंजी, CSR या दोनों पेस्ट करें।
- सार्वजनिक कुंजियों की तुलना करें और दी गई प्रत्येक वस्तु का परिणाम पढ़ें।
गोपनीयता और सीमाएँ
सब कुछ आपके ब्राउज़र में चलता है। आपकी इमेज, कुंजियाँ और पेस्ट किया गया डेटा इस टूल द्वारा अपलोड या सहेजा नहीं जाता।
संबंधित टूल्स
अक्सर पूछे जाने वाले सवाल
क्या मिलान होने का मतलब है कि प्रमाणपत्र विश्वसनीय है?
नहीं। मिलान केवल सार्वजनिक कुंजियों की तुलना करता है। यह प्रमाणपत्र के हस्ताक्षर, समय-सीमा, होस्टनेम या विश्वास श्रृंखला की पुष्टि नहीं करता।
क्या एन्क्रिप्ट की गई निजी कुंजियाँ समर्थित हैं?
नहीं। बिना एन्क्रिप्शन वाली PEM कुंजी का उपयोग करें। कुंजियों को केवल आपके ब्राउज़र में प्रोसेस किया जाता है और वे अपलोड या सहेजी नहीं जातीं।
क्या मैं निजी कुंजी के बिना CSR की तुलना कर सकता हूँ?
हाँ। उनकी सार्वजनिक कुंजियों की तुलना करने के लिए प्रमाणपत्र और CSR पेस्ट करें। यदि आप निजी कुंजी भी देते हैं, तो उसका परिणाम अलग से दिखाया जाता है।
मुफ़्त टूल · आपके ब्राउज़र में बार चलता है · अकाउंट की ज़रूरत नहीं