Entwickler / Zertifikate
Zertifikat-Schlüssel-Abgleich
Vergleiche ein Zertifikat mit einem privaten RSA- oder EC-Schlüssel und/oder einer CSR direkt im Browser, um zu prüfen, ob ihre öffentlichen Schlüssel übereinstimmen.
Zertifikat-Schlüssel-Abgleich: Extrahiert jeden öffentlichen Schlüssel, bringt ihn in eine einheitliche Darstellung und vergleicht ihn mit dem öffentlichen Schlüssel des Zertifikats. RSA und EC werden unterstützt, einschließlich privater PKCS#8-Schlüssel, privater RSA-PKCS#1-Schlüssel und EC-Schlüsseln mit Parametern für benannte Kurven. Läuft zu 100% lokal in deinem Browser, ohne Datei-Uploads zum Server.
- Kategorie
- Entwicklerwerkzeuge
- Ausführungen
- In deinem Browser
- Kosten
- Kostenlos · ohne Anmeldung
- Verfügbarkeit
- Einsatzbereit
Läuft vollständig in deinem Browser
Schlüssel und Zertifikate bleiben in deinem Browser. Übereinstimmende Schlüssel bestätigen weder das Vertrauen in das Zertifikat noch dessen Ablaufdatum.
Darstellung des öffentlichen Schlüssels
RFC 5280 (https://www.rfc-editor.org/rfc/rfc5280) beschreibt die Informationen zum öffentlichen Schlüssel, die Zertifikate enthalten. Der Vergleich der normalisierten Darstellung erkennt denselben Schlüssel in einem Zertifikat und einer Anfrage.
Formate privater Schlüssel
RFC 5208 (https://www.rfc-editor.org/rfc/rfc5208) beschreibt PKCS#8, während RFC 5915 (https://www.rfc-editor.org/rfc/rfc5915) EC-Privatschlüssel beschreibt. Diese Seite akzeptiert unverschlüsselte Schlüssel und fragt nicht nach einer Passphrase.
So benutzt du es
- Füge ein PEM-Zertifikat ein.
- Füge einen unverschlüsselten privaten Schlüssel, eine CSR oder beides ein.
- Vergleiche die öffentlichen Schlüssel und lies das Ergebnis für jedes bereitgestellte Objekt ab.
Datenschutz & Einschränkungen
Alles läuft in deinem Browser. Deine Bilder, Schlüssel und eingefügten Daten werden von diesem Tool weder hochgeladen noch gespeichert.
Ähnliche Tools
Häufige Fragen
Bedeutet eine Übereinstimmung, dass das Zertifikat vertrauenswürdig ist?
Nein. Die Übereinstimmung vergleicht nur öffentliche Schlüssel. Die Signatur, Gültigkeit, den Hostnamen oder die Vertrauenskette des Zertifikats wird dadurch nicht überprüft.
Werden verschlüsselte private Schlüssel unterstützt?
Nein. Verwende einen unverschlüsselten PEM-Schlüssel. Schlüssel werden ausschließlich in deinem Browser verarbeitet und weder hochgeladen noch gespeichert.
Kann ich eine CSR ohne den privaten Schlüssel vergleichen?
Ja. Füge das Zertifikat und die CSR ein, um ihre öffentlichen Schlüssel zu vergleichen. Wenn du zusätzlich einen privaten Schlüssel angibst, wird sein Ergebnis separat angezeigt.
Kostenloses Tool · läuft in deinem browser · kein Konto nötig