Sviluppatore / Certificati

Convertitore PEM e DER

Converti dati di certificati, chiavi e CSR tra PEM e DER binario, base64 o esadecimale, con rilevamento del tipo e conversione RSA PKCS#1/PKCS#8.

Convertitore PEM e DER: Controlla la codifica, identifica le strutture supportate di certificati, richieste e chiavi e crea file PEM o DER da scaricare. Mantenere la struttura conserva esattamente i byte DER. Le chiavi private RSA possono anche essere convertite in contenitori PKCS#8 oppure estratte da contenitori PKCS#8 come PKCS#1. Funziona al 100% localmente nel browser, senza caricare file sul server.

Esecuzioni
Nel browser
Costo
Gratuito · senza registrazione
Disponibilità
Pronto all'uso
Convertitore PEM e DERElaborazione locale

Funziona interamente nel browser

Etichette e codifiche PEM

RFC 7468 (https://www.rfc-editor.org/rfc/rfc7468) definisce le codifiche testuali PEM per certificati, richieste e chiavi. La struttura rilevata deve corrispondere all’etichetta.

Contenitori delle chiavi RSA

RFC 8017 (https://www.rfc-editor.org/rfc/rfc8017) definisce le strutture delle chiavi RSA e RFC 5208 (https://www.rfc-editor.org/rfc/rfc5208) descrive i contenitori delle chiavi private PKCS#8. La conversione non verifica le firme né decritta le chiavi.

Come usarlo

  1. Incolla PEM, base64 o esadecimale, oppure scegli un file DER binario.
  2. Mantieni la struttura oppure scegli una conversione per chiave privata RSA.
  3. Converti, controlla il tipo rilevato e scarica PEM o DER.

Privacy e limitazioni

Tutto funziona nel tuo browser. Le tue immagini, chiavi e i dati incollati non vengono caricati né salvati da questo strumento.

Strumenti correlati

Domande frequenti

La conversione da PEM a DER modifica la chiave?

Mantenere la struttura modifica solo la rappresentazione testuale o binaria. La conversione delle chiavi private RSA modifica il contenitore, mantenendo invariato il materiale della chiave.

È possibile decrittografare una chiave cifrata?

No. I contenitori PKCS#8 cifrati possono essere ricodificati, ma questo strumento non li decrittografa né ne convalida i contenuti.

Quali input sono supportati?

Un certificato, CSR, chiave pubblica o chiave privata alla volta. Sono riconosciute le strutture di chiavi PKCS#8, RSA PKCS#1 ed EC SEC1. I file binari devono essere DER, non file di testo contenenti PEM.

Strumento gratuito · nel browser esecuzioni · senza account