开发者 / 证书

PEM和DER转换器

在PEM和二进制DER、base64或十六进制之间转换证书、密钥和CSR数据,并支持类型检测及RSA PKCS#1/PKCS#8转换。

PEM和DER转换器: 检查编码,识别受支持的证书、请求和密钥结构,并生成PEM或DER下载文件。保留结构会保留完全相同的DER字节。RSA私钥还可以封装为PKCS#8,或解封装为PKCS#1。 完全在浏览器中本地运行,文件不会上传到服务器。

使用次数
在浏览器中
费用
免费·无需注册
可用性
可直接使用
PEM和DER转换器本地处理

完全在浏览器中运行

PEM标签和编码

RFC 7468(https://www.rfc-editor.org/rfc/rfc7468)定义了证书、请求和密钥的PEM文本编码。检测到的结构必须与标签一致。

RSA密钥容器

RFC 8017(https://www.rfc-editor.org/rfc/rfc8017)定义了RSA密钥结构,RFC 5208(https://www.rfc-editor.org/rfc/rfc5208)介绍了PKCS#8私钥容器。转换不会验证签名,也不会解密密钥。

使用方法

  1. 粘贴PEM、base64或十六进制内容,或选择二进制DER文件。
  2. 保留结构,或选择RSA私钥转换。
  3. 进行转换,查看检测到的类型,并下载PEM或DER。

隐私与限制

所有操作都在你的浏览器中运行。此工具不会上传或保存你的图片、密钥和粘贴的数据。

相关工具

常见问题

PEM转换为DER会改变密钥吗?

保留结构时,只会改变文本或二进制表示方式。RSA私钥转换会改变容器,但会保留相同的密钥材料。

可以解密加密的密钥吗?

不可以。加密的PKCS#8容器可以重新编码,但此工具不会解密它们,也不会验证其内容。

支持哪些输入?

一次只能处理一个证书、CSR、公钥或私钥。工具可以识别PKCS#8、RSA PKCS#1和EC SEC1密钥结构。二进制文件必须是DER,而不是包含PEM的文本文件。

免费工具·使用在浏览器中次·无需账户