개발자 / 인증서
PEM 및 DER 변환기
인증서, 키, CSR 데이터를 PEM과 바이너리 DER, base64 또는 16진수 간에 변환하고 유형을 감지하며 RSA PKCS#1/PKCS#8 변환을 지원합니다.
PEM 및 DER 변환기: 인코딩을 확인하고 지원되는 인증서, 요청 및 키 구조를 식별한 다음 PEM 또는 DER 다운로드 파일을 생성합니다. 구조를 유지하면 정확한 DER 바이트가 보존됩니다. RSA 개인 키는 PKCS#8로 래핑하거나 PKCS#1로 언래핑할 수도 있습니다. 서버에 파일을 전혀 업로드하지 않고 브라우저에서 100% 로컬로 실행됩니다.
- 카테고리
- 개발자 도구
- 실행 횟수
- 브라우저에서
- 비용
- 무료 · 가입 불필요
- 사용 가능 여부
- 사용 가능
브라우저에서 전부 실행됩니다
PEM 레이블 및 인코딩
RFC 7468(https://www.rfc-editor.org/rfc/rfc7468)은 인증서, 요청 및 키에 대한 PEM 텍스트 인코딩을 정의합니다. 감지된 구조는 레이블과 일치해야 합니다.
RSA 키 컨테이너
RFC 8017(https://www.rfc-editor.org/rfc/rfc8017)은 RSA 키 구조를 정의하며, RFC 5208(https://www.rfc-editor.org/rfc/rfc5208)은 PKCS#8 개인 키 컨테이너를 설명합니다. 변환 과정에서는 서명을 확인하거나 키를 복호화하지 않습니다.
사용 방법
- PEM, base64 또는 16진수를 붙여넣거나 바이너리 DER 파일을 선택합니다.
- 구조를 유지하거나 RSA 개인 키 변환을 선택합니다.
- 변환한 후 감지된 유형을 확인하고 PEM 또는 DER을 다운로드합니다.
개인정보 보호 및 제한사항
모든 작업은 브라우저에서 실행됩니다. 이미지, 키 및 붙여넣은 데이터는 이 도구에서 업로드하거나 저장하지 않습니다.
관련 도구
자주 묻는 질문
PEM을 DER로 변환하면 키가 변경됩니까?
구조를 유지하는 경우 텍스트 또는 바이너리 표현만 변경됩니다. RSA 개인 키 변환은 동일한 키 자료를 유지하면서 컨테이너를 변경합니다.
암호화된 키를 복호화할 수 있습니까?
아니요. 암호화된 PKCS#8 컨테이너는 다시 인코딩할 수 있지만, 이 도구는 해당 컨테이너를 복호화하거나 내용을 검증하지 않습니다.
어떤 입력을 지원합니까?
한 번에 인증서, CSR, 공개 키 또는 개인 키 하나를 지원합니다. PKCS#8, RSA PKCS#1 및 EC SEC1 키 구조를 인식합니다. 바이너리 파일은 DER이어야 하며, PEM이 포함된 텍스트 파일은 지원하지 않습니다.
무료 도구 · 브라우저에서회 실행 · 계정 불필요