Desenvolvedor / Certificados

Gerador de CSR

Gere uma chave privada RSA ou ECDSA e uma solicitação de certificado assinada no navegador, com campos do sujeito e nomes alternativos.

Gerador de CSR: Cria um novo par de chaves e uma solicitação PKCS#10 assinada usando o sujeito e os nomes alternativos solicitados. A assinatura da solicitação é verificada antes que os downloads sejam disponibilizados. A chave privada nunca sai do navegador e só é exibida por meio do download. Roda 100% localmente no seu navegador, sem enviar nenhum arquivo para o servidor.

Execuções
No seu navegador
Custo
Grátis · sem cadastro
Disponibilidade
Pronto para usar
Gerador de CSRProcessamento local

Roda inteiramente no seu navegador

Sua chave privada nunca sai deste navegador. Baixe-a e mantenha-a em segurança; não será possível recuperá-la depois que você fechar ou atualizar esta página.

Prefixos aceitos: DNS:, IP:, email: e URI:. Use nomes de domínio ASCII ou punycode.

Solicitações de certificado

O PKCS#10 define a solicitação assinada que contém o seu assunto, a chave pública e as extensões solicitadas. A RFC 2986 (https://www.rfc-editor.org/rfc/rfc2986) descreve sua estrutura.

Estruturas PEM e de certificados

A RFC 7468 (https://www.rfc-editor.org/rfc/rfc7468) define os rótulos textuais PEM. A RFC 5280 (https://www.rfc-editor.org/rfc/rfc5280) descreve os assuntos dos certificados e os nomes alternativos. Esses formatos transportam dados; por si só, não estabelecem confiança.

Como usar

  1. Informe um nome comum e os campos opcionais do sujeito.
  2. Escolha RSA 2048, 3072 ou 4096, ou ECDSA P-256 ou P-384; informe os nomes alternativos.
  3. Gere e baixe a chave privada e o CSR; depois, mantenha a chave privada em segurança.

Privacidade e limitações

Tudo é executado no seu navegador. Suas imagens, chaves e dados colados não são enviados nem salvos por esta ferramenta.

Ferramentas relacionadas

Perguntas frequentes

O que devo enviar à autoridade certificadora?

Envie o CSR e mantenha a chave privada em segurança. A chave privada nunca sai do navegador durante a geração; não é possível recuperá-la depois que você fecha ou atualiza esta página.

Quais nomes alternativos posso informar?

Use os prefixos DNS:, IP:, email: ou URI:, um por linha. IPv4 e IPv6 são aceitos. Use nomes de domínio ASCII ou punycode para domínios internacionalizados.

Qual formato de download é usado para a chave privada?

A chave é baixada como PKCS#8 PEM não criptografado. Armazene-a com segurança; qualquer pessoa que obtiver a chave poderá usá-la. Para compará-la com um certificado emitido, use o comparador de chave e certificado.

Ferramenta grátis · no seu navegador execuções · não precisa de conta