개발자 / 인증서

CSR Generator

브라우저에서 RSA 또는 ECDSA 개인 키와 서명된 인증서 요청을 생성합니다. 주체 필드와 대체 이름을 설정할 수 있습니다.

CSR Generator: 입력한 주체와 요청한 대체 이름을 사용하여 새 키 쌍과 서명된 PKCS#10 요청을 생성합니다. 다운로드를 제공하기 전에 요청 서명을 확인합니다. 개인 키는 브라우저 밖으로 나가지 않으며 다운로드를 통해서만 표시됩니다. 서버에 파일을 전혀 업로드하지 않고 브라우저에서 100% 로컬로 실행됩니다.

카테고리
개발자 도구
실행 횟수
브라우저에서
비용
무료 · 가입 불필요
사용 가능 여부
사용 가능
CSR 생성기로컬 처리

브라우저에서 전부 실행됩니다

개인 키는 이 브라우저 밖으로 나가지 않습니다. 다운로드하여 안전하게 보관하십시오. 이 페이지를 닫거나 새로 고친 후에는 복구할 수 없습니다.

사용할 수 있는 접두사는 DNS:, IP:, email:, URI:입니다. ASCII 도메인 이름 또는 퓨니코드를 사용하십시오.

인증서 요청

PKCS#10은 주체, 공개 키 및 요청된 확장 기능을 포함하는 서명된 요청을 정의합니다. RFC 2986(https://www.rfc-editor.org/rfc/rfc2986)에서 그 구조를 설명합니다.

PEM 및 인증서 구조

RFC 7468(https://www.rfc-editor.org/rfc/rfc7468)은 텍스트 PEM 레이블을 정의합니다. RFC 5280(https://www.rfc-editor.org/rfc/rfc5280)은 인증서의 주체와 대체 이름을 설명합니다. 이러한 형식은 데이터를 전달할 뿐이며, 그 자체로 신뢰를 설정하지는 않습니다.

사용 방법

  1. 일반 이름과 선택적 주체 필드를 입력합니다.
  2. RSA 2048, 3072 또는 4096, ECDSA P-256 또는 P-384 중에서 선택하고 대체 이름을 입력합니다.
  3. 개인 키와 CSR을 생성하고 다운로드한 다음 개인 키를 안전하게 보관합니다.

개인정보 보호 및 제한사항

모든 작업은 브라우저에서 실행됩니다. 이미지, 키 및 붙여넣은 데이터는 이 도구로 업로드하거나 저장하지 않습니다.

관련 도구

자주 묻는 질문

인증 기관에 무엇을 보내야 합니까?

CSR을 보내고 개인 키는 안전하게 보관하십시오. 생성 중 개인 키는 브라우저 밖으로 나가지 않으며, 이 페이지를 닫거나 새로 고친 후에는 복구할 수 없습니다.

어떤 대체 이름을 입력할 수 있습니까?

각 줄에 하나씩 DNS:, IP:, email: 또는 URI: 접두사를 사용하십시오. IPv4와 IPv6를 사용할 수 있습니다. 국제 도메인에는 ASCII 도메인 이름 또는 punycode를 사용하십시오.

개인 키에는 어떤 다운로드 형식이 사용됩니까?

키는 암호화되지 않은 PKCS#8 PEM 형식으로 다운로드됩니다. 안전하게 보관하십시오. 키를 얻은 사람은 누구나 사용할 수 있습니다. 발급된 인증서와 비교하려면 인증서 키 일치 도구를 사용하십시오.

무료 도구 · 브라우저에서회 실행 · 계정 불필요