開発者 / 証明書

CSR生成ツール

ブラウザでRSAまたはECDSAの秘密鍵と署名付き証明書リクエストを生成します。サブジェクト項目と代替名に対応しています。

CSR生成ツール: 入力したサブジェクトと指定した代替名を使用して、新しい鍵ペアと署名付きPKCS#10リクエストを作成します。ダウンロードを提供する前に、リクエストの署名を検証します。秘密鍵がブラウザの外部に出ることはなく、ダウンロードによってのみ表示されます。 サーバーへのファイルアップロードは一切なく、100%ブラウザ内でローカル実行します。

カテゴリ
開発者ツール
実行回数
ブラウザ内で
コスト
無料 · 登録不要
提供状況
すぐに使えます
CSRジェネレーターローカル処理

完全にブラウザ内で実行します

秘密鍵がこのブラウザの外に出ることはありません。ダウンロードして安全に保管してください。このページを閉じたり更新したりした後に復元することはできません。

使用できる接頭辞はDNS:、IP:、email:、URI:です。ASCIIドメイン名またはPunycodeを使用してください。

証明書署名要求

PKCS#10は、サブジェクト、公開鍵、要求する拡張を含む署名済みの要求を定義しています。RFC 2986(https://www.rfc-editor.org/rfc/rfc2986)でその構造が説明されています。

PEMと証明書の構造

RFC 7468(https://www.rfc-editor.org/rfc/rfc7468)は、テキスト形式のPEMラベルを定義しています。RFC 5280(https://www.rfc-editor.org/rfc/rfc5280)では、証明書のサブジェクトと代替名について説明されています。これらの形式はデータを格納するものであり、それだけで信頼性を確立するものではありません。

使い方

  1. コモンネームと、必要に応じてサブジェクト項目を入力します。
  2. RSA 2048、3072、4096、またはECDSA P-256、P-384を選択し、代替名を入力します。
  3. 秘密鍵とCSRを生成してダウンロードし、秘密鍵を安全に保管します。

プライバシーと制限事項

すべての処理はブラウザ内で実行されます。このツールによって画像、鍵、貼り付けたデータがアップロードまたは保存されることはありません。

関連ツール

よくある質問

認証局には何を送ればよいですか?

CSRを送信し、秘密鍵は安全に保管してください。生成中に秘密鍵がブラウザの外部に出ることはありませんが、このページを閉じたり更新したりすると復元できません。

どのような代替名を入力できますか?

1行に1つずつ、DNS:、IP:、email:、またはURI:のプレフィックスを付けて入力してください。IPv4とIPv6に対応しています。国際化ドメインにはASCIIドメイン名またはpunycodeを使用してください。

秘密鍵にはどのダウンロード形式が使用されますか?

鍵は暗号化されていないPKCS#8 PEM形式でダウンロードされます。取得した人は使用できるため、安全に保管してください。発行済み証明書と比較するには、証明書と鍵の照合を使用してください。

無料ツール · ブラウザ内で · アカウント不要